System requirements for QuickBooks Pro/Premier & Enterprise 2018

System requirement QuickBooks 2018 gives you the information required to ensure your desktop hardware, software, and OS meet the minimum specification for your version of Quickbooks Desktop. In today’s blog, we will discuss what operating system, hardware, database server, disk space is required to install the latest version of Quickbooks Pro, Premier and Enterprise.

Quickbooks Pro/Premier and Enterprise 18.0

Operating systems

  • Windows 8.1: All editions, including 64-bit, natively installed
  • Windows 7 SPI: All editions, including 64-bit, natively installed
  • Windows Server 2016
  • Windows Server 2012 R2
  • Windows Server 2011 SPI
  • Windows Server 2008 R2 SPI

Database Servers

  • Windows: Windows Server 2016, Windows Server 2012 R2, Windows Server 2011 R2, Windows Server 2008 R2 SPI, natively installed.
  • Linux: When using QBES Database Server-Only installation – OpenSuse 42.2, Fedora 25, Red Hat 7

Browser Requirement

  • Internet Explorer 11 (32-bit)

Hardware and Operating system requirements(client and server)

  • Processor: 4 GHz minimum
  • RAM: 4GB minimum, 8GB recommended server RAM Requirement
  • 1-5 Users: 8GB RAM
  • 10 Users: 12 GB RAM
  • 15 Users: 16GB RAM
  • 20 Users: 20+GB RAM

To get support for QuickBooks setup, update, installation, backup & restore, Dial 1-855-441-4417.

Disk Space:

  • 5GB of disk space
  • Additional Software: 60 MB for Microsoft .NET 4.6 Runtime, provided on the Quickbooks CD
  • Additional requirements for Intuit Data Protect in Quickbooks Connected Services offering.

Windows

  • US version of window (if using US Quickbooks software), Canadian version of Windows (if using Canadian QuickBooks software)
  • Windows Server 2012 R2, Windows Server 2011 R2, Windows Server 2008 R2, Windows Server 2008 R2 SPI or
  • Windows 7 SPI, natively installed and in which Regional setting is supported when set to English (United State/Canada) with keyboard setting to US/CA only.
  • In windows Administrator rights required for the server computer when hosting Multi-User access
  • Natively installed- means it was installed on a specific system or an environment that it was designed for. This also means it does not need to run in a virtual environment emulation software.

Optical Drive: 4X DVD-ROM drive required for CD installation (unless QuickBooks is downloaded from the Intuit server)

Software Compatibility:

  • Quickbooks is efficient of integrating with hundreds of third-party applications. The following integration is assigned with QB, additional RAM will increase the use of these characteristic.
  • Microsoft Office
  • Office 2016 (contain outlook 2016) both on 32 and 64-bit. Office 2010 and Office.
  • Email Estimates, Invoices and other forms with Microsoft Outlook 2010-2016, Microsoft Outlook with Office 365, Gmail, Yahoo Mail and Outlook.com, other SMTP-supporting e-mail clients
  • Preparing letters requires Microsoft Word 2016,2013 or 2010 or Office 365(includes 64-bit)
  • Exporting REPORTS REQUIRES ms excel 2016,2013 or 2010 or Office 365 (include 64-bit)
  • Contact Synchronization with MS Outlook required Outlook 2010 (32-bit)
  • Contact Synchronization does not work with the MS Business Contact Manager Outlook plug-in. If a synchronization is performed, twin records could result.
  • Quickbooks Point of Sale V12.0, V11.0 (applies to the US only)
  • TurboTax 2016 and 2015 (Personal and Business)
  • Lacerte 2016 and 2015 (applies to the US only)
  • Pro series tax years 2016 and 2015 (applies to the US only)
  • Internet Explorer 11

See also: System Requirement for QuickBooks 2018

Firewall and antivirus compatibility

  • Quickbooks Pro, Premier 2018, Enterprise 18.0 has been checked with this firewall and antivirus products.
  • Avast
  • AVG
  • Symantec
  • ESET
  • Avira
  • Kaspersky
  • McAfee
  • Bitdefender
  • Malwarebytes

Note: QB will work with system running RAID but it is not approved because performance matter may cause QuickBooks to operate slowly.

Related Blogs/Articles:

System requirement for QuickBooks for MAC.

What is the system requirement for QuickBooks POS?

System Requirement for the Enterprise of QuickBooks 2018.